Virtual ECDIS / Safebridge FreePlay Error
Incident Report for Mintra
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 13:18 UTC
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 06:17 UTC
This incident affected: ECDIS/Free Play.