This is a Trainingportal Major release that will bring new features, UI improvements and fixes for various reported issues, as well as increased stability & performance for Trainingportal.
Is system downtime expected?
Whilst the scheduled maintenance is ongoing, there may be brief outages/intermittent errors. Trainingportal Offline Synchronisation will be temporarily delayed but will then resume as normal.
What is included in this release?
• Course Recommendations • For You Page • Various Bug Fixes and Improvements
Posted Sep 18, 2025 - 16:29 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Sep 02, 2025 - 13:02 UTC
This scheduled maintenance affects: Trainingportal and Trainingportal Offline (TPOS).