Safebridge website non-operational
Incident Report for Mintra
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 08:20 UTC
Update
Issue with the Trainingportal website has been resolved. The issue with the Safebridge website still persists and we are still working on it.
Posted Sep 02, 2024 - 06:18 UTC
Investigating
We are currently investigating this issue.
Posted Sep 02, 2024 - 05:06 UTC
This incident affected: Trainingportal and SafeLearn.