MyCert SSL Certificate Issue
Incident Report for Mintra
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 13:54 UTC
Investigating
Users attempting to access myCert may see an error related to the sites SSL certificate.
This is currently being investigated.
Posted Mar 25, 2024 - 11:38 UTC
This incident affected: MyCert.