ECDIS - Virtual ECDIS Simulator Error
Incident Report for Mintra
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 08:44 UTC
Investigating
We are currently investigating this issue.
Posted Oct 04, 2024 - 12:00 UTC
This incident affected: ECDIS/Free Play.