Virtual ECDIS Simulators Degraded Performance

Incident Report for Mintra

Update

We are continuing to monitor for any further issues.
Posted Feb 06, 2026 - 13:51 UTC

Monitoring

We are continuing to monitor Virtual ECDIS Performance. The following Virtual ECDIS remain in Error:
- Chartworld eGlobe G2
- Anschütz Synapsis ECDIS NX
- Consilium ECDIS G2
- Sperry Marine VisionMaster

Practical Questions remain off for the above three Type-Specific ECDIS exams
Posted Jan 07, 2026 - 16:22 UTC

Update

We are continuing to investigate this issue. Users may encounter errors when accessing "Practice Mode".

The practical questions for the ECDIS Type-Specific Exams have been disabled
Posted Nov 27, 2025 - 14:29 UTC

Investigating

Some users may frequently experience a message indicating all Virtual ECDIS VMs are currently occupied. We are currently investigating this as a priority.
Posted Nov 27, 2025 - 11:32 UTC
This incident affects: ECDIS/Free Play.