Virtual ECDIS / Safebridge FreePlay Error
Incident Report for Mintra
Resolved
This incident has been resolved.
Posted Aug 25, 2024 - 12:19 UTC
Investigating
Users may see a message stating all simulators are currently occupied.
We are currently investigating this.
Posted Aug 25, 2024 - 10:29 UTC
This incident affected: ECDIS/Free Play.